So-net無料ブログ作成

【Ubuntu 9.10】 Ubuntu 9.10 64bit版でATIグラフィックドライバ(10.3)のパッケージが作れない問題を無理やり対処  [ubuntu]

ATIドライバが10.xになってから、パッケージが作れない。。

例えば、下記のコマンドを入力すると、

ubuntu:~$ ./ati-driver-installer-10-3-x86.x86_64.run --buildpkg Ubuntu/karmic

最後に下記のようなエラーで終わる。(./ati-driver-installer-10-3-x86.x86_64.run としてGUIならインストールできるのですが。。)

dpkg-shlibdeps: error: no dependency information found for /usr/share/ati/lib64/libQtCore.so.4 (used by debian/xorg-driver-fglrx/usr/sbin/amdnotifyui).
dh_shlibdeps: dpkg-shlibdeps returned exit code 2
make: *** [binary-predeb-IMPL/xorg-driver-fglrx] Error 1
dpkg-buildpackage: error: debian/rules binary gave error exit status 2

調べているうちに、下記のアンインストール(以前にも見たのですが忘れてました)をして、パッケージ作れないかな?と思ってやってみました。

https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver#Problem:%20%20Need%20to%20fully%20remove%20-fglrx%20and%20reinstall%20-ati%20from%20scratch

まずは、下記のページの通りやっていきました。

http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide#Before_you_start

やはり作れず。今度は、下記のエラーがでました。

dpkg-shlibdeps: failure: couldn't find library libfglrx_gamma.so.1 needed by debian/fglrx-driver/usr/bin/fglrx_xgamma (its RPATH is '').
Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
dh_shlibdeps: command returned error code 512
make: *** [binary] Error 1
dpkg-buildpackage: failure: debian/rules binary gave error exit status 2

今度は、libfglrx_gamma.so.1が無いと言われてる。やけになって、./ati-driver-installer-10-3-x86.x86_64.runのあるディレクトリから

mkdir foo
cd foo
../ati-driver-installer-10-3-x86.x86_64.run --extract
cd fglrx-install.kALdJt/arch/x86_64/usr/X11R6/lib64
ln -s  libfglrx_gamma.so.1.0 libfglrx_gamma.so.1
cd ../../../../..
./ati-installer.sh 10.3 --buildpkg Ubuntu/karmic

としたら、sucessfulと出ました。(青字の所は、展開した時々によって変わります)

cd ..

としたら、いつもの6つのdebファイルができてました。

後は、前述のubuntuのATIドライバのインストールマニュアルの4番と5番に従ってインストールしました。

http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide#4._Install_.debs.

で、再起動したらインストール完了。一応 fglrxinfo や glxinfo で見る限り大丈夫そう。

再起動してから、

./ati-driver-installer-10-3-x86.x86_64.run --buildpkg Ubuntu/karmic

と入力したら、素直にパッケージができてしまいました。。(・・?))アレ

やっぱりよく分かりません。(私が修正したのと、後で作ったのでパッケージ同士のdiffを取ってみればよかったと思ったのですが、消してしまい後の祭りでした。)

 ←A3サイズのマウスパッドだそうです。

   でか~ キーボードが乗る!


nice!(1)  コメント(0) 
共通テーマ:パソコン・インターネット

nice! 1

コメント 0

コメントを書く

お名前:
URL:
コメント:
画像認証:
下の画像に表示されている文字を入力してください。

Facebook コメント

この広告は前回の更新から一定期間経過したブログに表示されています。更新すると自動で解除されます。

×

この広告は1年以上新しい記事の更新がないブログに表示されております。