So-net無料ブログ作成

【Ubuntu 9.10】もう ATIグラフィックドライバ 10.3 (fglrx 8.712) にアップデート [ubuntu]

つい先日(3/21)にATIドライバ10.2を入れたらCompizが上手く動かなくて悪戦苦闘して10.1を入れたと思ったら。。。

3/24に次のバージョン、10.3 (fglrx8.712)が出てた。。(;‾Д‾)なっ?

もう、インストールは下記のコマンドを打って、

sudo ./ati-driver-installer-10-3-x86.x86_64.run

他のカーネルの為に、

sudo update-initramfs -k all -u

でお終い。10分程度の作業。

今度はCompizも一応動いてるし、you tube も見れるということはFlashも大丈夫そう。

しかし、なぜか10.xになってからパッケージが作れなくなった問題が解消されない。そもそも、下記を入力すると途中でエラーがでる。

./ati-driver-installer-10-3-x86.x86_64.run --listpkg

そこで、--extract オプションでばらしてみたら、

packages/Slackware/ati-packager.sh の56行目にありえない "[" が付いてた。

でも、Ubuntuとは違うディストリビュートのディレクトリなので、関係なさそう。

./packages/Ubuntu/ati-packager.sh --buildpkg karmic

と打ってみたけどやっぱり同じエラー。10.xになってから下記を実行し始めると、dpkg-shlibdepsがwarningを吐きまくり、最後にはerrorになってダメになる。64bit版だけかな~。

dh_shlibdeps -pxorg-driver-fglrx   "-Xlib32"

・・・よく分からない。(o_□_)oダメ 
nice!(0)  コメント(0) 
共通テーマ:パソコン・インターネット

nice! 0

コメント 0

コメントを書く

お名前:
URL:
コメント:
画像認証:
下の画像に表示されている文字を入力してください。

Facebook コメント

この広告は前回の更新から一定期間経過したブログに表示されています。更新すると自動で解除されます。

×

この広告は1年以上新しい記事の更新がないブログに表示されております。