So-net無料ブログ作成
検索選択

【Ubuntu】Gnome Pie (アプリケーション・ランチャー) 0.4 リリース -- 設定画面が大幅変更 [ubuntu]

下記のOMG! Ubuntuの記事でGnome Pieが0.4にバージョンアップした事を知りました。

SS-gnome-pie04-011.JPG

http://www.omgubuntu.co.uk/2012/01/new-gnome-pie-release/

本家?のページ:

http://www.simonschneegans.de/?page_id=296

PPAからインストールできます。PPAのページは下記。

https://launchpad.net/~simonschneegans/+archive/testing

私は早速Ubuntu 12.04(Precise)にインストールしました。

 

< インストール方法 >

対象バージョンは2012/1/22時点で、Ubuntu 10.04(Lucid)からUbuntu 12.04(Precise)までです。

端末から、下記を入力します。

sudo add-apt-repository ppa:simonschneegans/testing
sudo apt-get update
sudo apt-get install gnome-pie

この後、一度ログアウト&ログインをすれば使えるはずです。

 

< 簡単な設定画面の説明 >

パネル(インジケーター)アイコンを右クリックしてメニューをだして、「設定」を選ぶと設定画面がでます。

SS-gnome-pie04-002.JPG

設定画面が、以前よりWYSIWYGのようになりました。

1) アプリケーションの登録

SS-gnome-pie04-003.JPG

空きエリアにマウスポインターを持っていくと、上図のように+印がでます。ここでクリックすると登録画面がでます。

SS-gnome-pie04-004.JPG

上図のように、Slice Typeを「Launch Application」にセットしておいて、Name of the Sliceの欄に登録したい(メニューで表示される名前)を記述し、Command to executeの欄に実行コマンドを記述してOKボタンを押します。

2) アプリケーションの編集

SS-gnome-pie04-006.JPG

編集したいアイコンの通行止めマークにかからないようにマウスポインターを持っていくと、真ん中のランチャー名の下に「Click to edit」とでるので、左クリックすると編集画面がでます。編集画面は登録の時と同じです。

3) アプリケーションの削除

SS-gnome-pie04-005.JPG

削除したいアイコンの通行止めマーク上にマウスポインターを持っていくと、真ん中のランチャー名の下に「Click to delete」とでるので、左クリックすると削除されます。

<ショートカットの変更>

SS-gnome-pie04-007.JPG

カテゴリ(Pie)名の下にショートカットの組み合わせがありますので、そこをクリックします。すると下図のウインドウがでます。

SS-gnome-pie04-009.JPG

ここで上図のように、ショートカットの組み合わせが記述してある所をクリックすると下図になります。

SS-gnome-pie04-008.JPG

ここで、キーボードで登録したいショートカットの組み合わせを押します。すると新たに登録したショートカットの表示になるはずです。

※私の意見ですが、右手でマウスを操作する人は、左手のみで押せるショートカットがよいと思います。理由はマウスから手を離さなくて済む為です。なので、左利きの人は右手のみで押せるショートカットがよいと思います。

< 全体の設定>

左上のGnenral Settingsを押すと、Gnome Pie全体の設定が出来ます。

SS-gnome-pie04-010.JPG

一番上の「Start Gnome-Pie on login」にチェックを入れると、ログイン時に自動起動してくれます。もし、チェックを入れてもログイン時に自動起動しないようだったら、「自動起動するアプリケーションの設定」で下図のように登録すれば起動するはずです。

SS-gnome-pie04-001.JPG

次の、Display Panel Iconは、パネル上のアイコンの表示/非表示のチェックです。

その下のリストで、Gnome-Pieのテーマを選ぶことが出来ます。好みのテーマを選んでください。

説明は以上です。

< 余談 >

私は、Gnome-Pieを知ってから、必ずGnome-Pieを入れるようにしています。

というのは、UnityやGnome-Shellがクラッシュして使えない状態になった時に、Gnome-Pieは動いている事があります。(もちろん、Gnome-Pieも動かない時も多々ありますが。。)Gnome-Pieが動いていれば、ログアウトやシャットダウンができるので、PCをリセットする回数が少なくなります。

上記と同様な理由で、Gnome-Pieのアプリーケーションには端末を必ず登録するようにしています。

なので、私にとってGnome-Pieは非常時のランチャーの役目を果たしています。

 

 ←Eee Pad TF201

   昨日(2011/1/21)発売のASUSのタブレットPC
   Android 3.2.1だけどAndroid 4.0にバージョンアップ予定らしい。
   このタブレットの目玉はクワッド・コア。
   ただ、海外ではすでに販売されていて、やっと日本発売
   という感じだし、なんか高い・・・
   買うなら4.0にアップデートされて、値段が落ち付いてからかな~


nice!(0)  コメント(2) 
共通テーマ:パソコン・インターネット

【Ubuntu,Windows】Flash Player 11.2 Beta 4 (11.2.202.183 ) リリース -- 特に変化はないかな~ [ubuntu]

2012/1/19(日本では1/20)にFlash Player 11.2 Beta 4(11.2.202.183)がリリースされました。

http://labs.adobe.com/technologies/flashplatformruntimes/flashplayer11-2/

ダウンロードリンク:

http://labs.adobe.com/downloads/flashplayer11-2.html

今回、Beta 4になって新しくなった機能は、

Drivers gating for hardware acceleration relaxed (new in beta 4)

Throttling event (new in beta 4)

の2つなのですが・・・私は英語が苦手なのと、Flashについてあまり知らないので意味がよく分りません。

恐らくですが、対応ドライバーを2009/1/1以降だったのを2008/1/1以降まで拡大したということと、ThrottleEvent(早送りやスロー再生とかのイベントかな??)をポーズやリジューム状態でも使えるようにしたということではないかと思います。(まったく、自信ないのです。)

< インストールしてみて>

[IE9:windows vista 32bit]

SS-flash11-041.JPG

普通に動きました。

※上図はF15の空中給油の動画です。

[firefox 9.0.1:widows vista 32bit]

SS-flash11-040.JPG

普通に動きました。

※上図は雪道のラリーです。 タイヤは細いの履くのですね。

[firefox 10 b5 :Ubuntu 12.04(precise) 32bit on Virtualbox 4.1.8]

SS-flash11-042.JPG

普通に動きました。

※上図はFF-X/X2とDragonfoceのAMVです。

 

Ubuntu に関してですが、インストール方法は『【Ubuntu,Windows】Flash Player 11.2 Beta 3 (11.2.202.160 ) リリース -- バグフィックスのみの模様 & Youtubeで確認したら面白いことが・・』を参考にして下さい。

ただ、alternativesの登録でmozilla-flashpluginだけでも動いていましたが、調べてみるとfirefox-flashpluginにも登録してありました。ですので、今回は下記の2つのalternatives登録のコマンドを入力しました。

sudo update-alternatives --install /usr/lib/firefox/plugins/flashplugin-alternative.so firefox-flashplugin /usr/lib/flashplugin-11-2-beta4/libflashplayer.so 60

sudo update-alternatives --install /usr/lib/mozilla/plugins/flashplugin-alternative.so mozilla-flashplugin /usr/lib/flashplugin-11-2-beta4/libflashplayer.so 60

今回のアップデートでは、私にとって、特に気になる部分はありませんでした。

 

 ←メモリースティック PROデュオ Mark2 4G (海外リテール品)

    日本版の同じ物を持っていますが、
    倍近い値段で購入した記憶が・・・
    海外版だとこんなに安いんですね。
    全く日本版と同じものなのか?、それとも違うのか?
    よく分りません。


nice!(0)  コメント(0) 
共通テーマ:パソコン・インターネット

アメリカのSOPA、PIPAの法案に反対するネットストライキに出くわしてしました [コンピュータ全般]

1つ前の記事『【Ubuntu】JAVA 7 (JDK 1.7.0) をPPAからインストールする方法』を書くのにWEB UPD8(http://www.webupd8.org/)にアクセスしたら・・・下図のような画像がいきなり出てきました。

SS-sensor-web-004.JPG

始めは驚いて、何だろう??と思って、下記とかを見ました。

http://www.atmarkit.co.jp/news/analysis/201201/18/sopa.html

http://www.rbbtoday.com/article/2012/01/18/85208.html

要するにアメリカで「オンライン海賊行為防止法案(Stop Online Piracy Act:SOPA)」および「IP保護法(PROTECT IP Act:PIPA)」という法案に反対する為に、アメリカ時間で18日の24時間ネットストライキをしているようで、それに出くわしてしまったみたいです。

wiki,google,mozillaとかが反対していて、特にアメリカのwikiはアメリカが18日の間は全く使えないはずです。すぐに下記の画像になってしまいます。

SS-sensor-web-003.JPG

それでGoogleは署名活動みたいのをしていて、Google(英語版)のトップページにアクセスすると「Tell Congress: Please don't censor the web!」(下図)と書かれているリンクがあります。

SS-sensor-web-001.JPG

これをクリックすると下図がでます。

SS-sensor-web-002.JPG

WEB UPD8はここにリンクを張っているようです。

他にはmozillaも反対を表明しているの下図のページとかがあります。

SS-sensor-web-005.JPG

では賛成の団体はというと、下記がそのリスト(PDFファイル)のようです。

http://judiciary.house.gov/issues/Rogue%20Websites/List%20of%20SOPA%20Supporters.pdf

賛成しているのはコンテンツを作成する側で、反対しているのはコンテンツを流通させる側という構図の様です。(自然とそうなりますよね。)

大変なのは、このストライキに出くわした方で、インターネットは道具として使うだけでそれほど知識を持っていない方です。

いきなり始めのスクリーンショットが出たら、ウイルスと勘違いする人もいるのでは?と思っています。

 

 ←USBメモリ 32G

    USBメモリの32Gもかなり安くなってきました。
    32Gあっても私には今は必要ありません。
    32Gの使い道としては、USBブートのWindows 7を
    作るとか・・・
    作成する方法はあるけど、ライセンス問題もあるような。。。


nice!(1)  コメント(0) 
共通テーマ:パソコン・インターネット

【Ubuntu】JAVA 7 (JDK 1.7.0) をPPAからインストールする方法 [ubuntu]

WEB UPD8を見たらJava 7 SDKをPPAからインストールする方法が載っていました。

http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html

PPAのページは下記。

https://launchpad.net/~webupd8team/+archive/java

2012/1/19時点で、対応しているUbuntuのバージョンは、10.04(Lucid)から12.04(Precise)です。

このPPAにはOracle(Sun) Java 7自体がパッケージになって置いてあるわけではなくて、Java 7のインストーラーがパッケージになって置いてあります。なので、パッケージをインストールすると、そこでJava 7をダウンロードしてきて入れる仕組みです。(adobe flashのパッケージも同様な仕組みです。)

Virtualbox上で動いているUbuntu 12.04(Precise)に、まだOracle Javaを入れていなかったので試しに入れてみました。

< インストール方法 >

端末から下記のコマンドで入ります。

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-jdk7-installer

< 確認方法 >

端末から下記を入力してみて下さい。

java -version

2011/1/19現在では、Java 7の最新バージョンは1.7.0_02(7u2)なので下図のようにでます。

SS-java7-ppa-004.JPG

基本的には、インストールした時にOracleが提供している最新のjavaのバージョンがインストールされるはずなので、javaのバージョンを下記のページなどのOracle-java関連サイトで確認しておいて下さい。

http://www.oracle.com/technetwork/jp/java/index.html

プラグインに関しては、下記にアクセスして「Javaバージョンの確認」と書いてある部分を押して少し待ちます。

http://java.com/ja/download/installed.jsp

すると下図の様に出るはずです。

SS-java7-ppa-002.JPG

また、firefoxのアドオンのプラグインページに下記の様に出るはずです。

SS-java7-ppa-001.JPG

上図をみるとJava(TM) Plug-in 1.7.0_02とあるのが分ると思います。ただ、ここにIceTea(Open Java 6のプラグイン)があるので、競合しないか心配ですが、私の所では今のところ大丈夫です。もし問題がありそうならIceTeaの方を無効化ボタンを押せばよいと思います。

ちなみに、/usr/lib/mozlla/pluginsのディレクトリをみると、libjavaplugin.so(Open Java) とlibnpjp2(Oracle Java 7)があります。

SS-java7-ppa-003.JPG

これはどちらもシンボリックリンクで、かつ、両方ともalternativesで切り替えられるようになっています。alternativesを使っているのに別々のリンクを作った理由は、私にはよく分りません。

 

 ←モンスターハンター3G

  モンスターハンター3Gが出た事すっかり忘れてた。
    いつもならすぐに購入している所ですが、
    今は他のことで忙しいのでやる暇がないです。
    それに3DSを購入するお金もない。。


nice!(0)  コメント(0) 
共通テーマ:パソコン・インターネット

【Ubuntu 12.04 alpha 1】2012/1/17にUbuntu 12.04のアップデートしてGTKテーマがなんかおかしくなったと思っていたら・・・ [ubuntu]

今日(2012/1/17)にアップデートをいつものようにしました。

そしたら。。。GTK-3.0のテーマがおかしくなってしまいました。

SS-nautilus-quick-003.JPG

上図を見てもらうと分ると思うのですが、プルダウンメニューの項目がめちゃくちゃ読みにくくなってしまいました。スクリーンショットはありませんが、右クリックの時に出るメニューも同じです。

とにかく、メニューの文字が今まで白だったのに黒に近い色になってしまいました。

上図は、Ambienceのテーマなので、Ambienceテーマが入っているlight-themeパッケージがミスをしたのかなと思ったら、3週間くらい変更がありません。

そこで、試しにHopeのテーマをいれてみました。

SS-nautilus-quick-002.JPG

やはり、同様にメニューが読みにくい状態です。

確認していないのですが、Gnome-Shellでも同様におかしくなるはずです。

そこで、1/17にアップデートしたパッケージを見てみると、gtk-3.0がアップデートされていました。恐らく、バグか仕様変更かわかりませんが、gtk-3.0が影響しているのかな~と思っていました。

それに、Ambienceテーマを適応している時に、gnome-tweak-toolを端末から起動すると下記のエラーが出ました。

Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1598:20: Invalid animation description

ところが、、、記事を書きながら、どうやって直すのかな??などと考えていたら、記事を書いている最中にlight-themeがアップデートされました。(1/18になっていました。)light-theme バージョンは、0.1.8.26です。

https://launchpad.net/ubuntu/+source/light-themes/0.1.8.26

アップデートしたら、直りました。 やはり、gtk 3.3.8に合わせて修正したようです。さらに、すぐ前に記述したTheme parsing errorも修正されていました。

SS-nautilus-quick-005.JPG

Ambienceは直ってめでたしめでたしですが、他のテーマはというと、もちろんまだ。

それで、どうやって直すかというと、light-themeのdiffを真似すれば直るはずです。

下記のコードをテーマディレクトリ内(/usr/share/themes/テーマ名/gtk-3.0/ 又は ~/.themes/テーマ名/gtk-3.0/)のスタイルシートの.menuitemが定義してある部分のすぐ上に入れて下さい。定義してあるスタイルシートはgtk-widget.cssが多いと思いますが、テーマによって異なります。

.menuitem * {
    color: @@color code@@;
}

@@color code@@は、実際のテーマに沿ってカラーコード(@define-color ruleで定義したものでもかまいません)を入れて下さい。

下記はHopeの例ですが、gtk-widget.ccs987行目以降にmenuitemの定義があったので、990行目から赤字の所を追加しました。

    987 /************
    988  * menuitem *
    989  ************/
    990 .menuitem * {
    991     color: @dark_fg_color;
    992 }
    993

そしたら、下図のように直ります。

SS-nautilus-quick-006.JPG

テーマ作成者の皆さんは、Ubuntu 12.04(Precise)用、つまりGTK 3.3.8以降に対応するには直さないとならないので、大変ですね。

 

 ←GPSロガー

    これ、2011年6月から販売されていたのを
    知りませんでした。
    これなら、IPX7の防水も付いてるし
    ヨットに乗る時使えるかな~と思ったのですが・・・
    なんか、これの上位版(Pro)のレビューを見ると
    防水がいまいちのような事が書いてあったので、(-_-;ウーン


nice!(0)  コメント(4) 
共通テーマ:パソコン・インターネット
メッセージを送る