So-net無料ブログ作成

【Ubuntu 11.10】Google Earth 6.1.0 インストール -- 文字化けも対処しましたが・・・ [ubuntu]

Google Earthがいつの間にか(2011/9/20ですが・・)アップデートしてました。

SS-GoogleEarth-610-003.jpeg

そこでUbuntu 11.10(Oneiric)に入れてみました。

インストールのやり方は以前記述した下記と同じです。

【Ubuntu 11.04】Google Earth 6.0.2 インストール (日本語文字化け対処)

ただ、今回はUbuntu 10.04からQt4ライブラリを持ってきました。ですので、下記のコマンドでダウンロードしました。

wget http://security.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqtcore4_4.6.2-0ubuntu5.3_i386.deb

wget http://security.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqtgui4_4.6.2-0ubuntu5.3_i386.deb

wget http://security.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-webkit_4.6.2-0ubuntu5.3_i386.deb

wget http://security.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libqt4-network_4.6.2-0ubuntu5.3_i386.deb

wget http://security.ubuntu.com/ubuntu/pool/main/q/qt4-x11/libphonon4_4.6.2-0ubuntu5.3_i386.deb

バージョンが違うので、上記リンクの「4) ファイルの展開」の展開するコマンドは下記になります。

dpkg -x libqtcore4_4.6.2-0ubuntu5.3_i386.deb core

dpkg -x libqtgui4_4.6.2-0ubuntu5.3_i386.deb gui

dpkg -x libqt4-network_4.6.2-0ubuntu5.3_i386.deb net

dpkg -x libqt4-webkit_4.6.2-0ubuntu5.3_i386.deb web

dpkg -x libphonon4_4.6.2-0ubuntu5.3_i386.deb phonon

それから上記リンクの「6) ファイルの退避と置き換え」のコピーしている部分は下記に変わります。

sudo cp ~/ge/core/usr/lib/libQtCore.so.4.6.2 libQtCore.so.4

sudo cp ~/ge/core/usr/lib/libQtGui.so.4.6.2 libQtGui.so.4

sudo cp ~/ge/net/usr/lib/libQtNetwork.so.4.6.2 libQtNetwork.so.4

sudo cp ~/ge/web/usr/lib/libQtWebKit.so.4.6.2 libQtWebKit.so.4

sudo cp ~/ge/phonon/usr/lib/libphonon.so.4.4.0 libphonon.so.4

ここで問題となるのがやはりGoogle Earth 5.2のimageformatプラグインがいることです。ところが、下記のGoogle Earthのダウンロードページで「以前のGoogle Earth」をダウンロードしようとすると6.0になってます。

http://www.google.co.jp/intl/ja/earth/index.html

なので、Google Earth 5.2がすでに無いのかと思ってしまいました。

ところが、下記のコマンドでダウンロードすると2011/11/24の時点ではGoogle Earth 5.2がダウンロードできました。

wget http://dl.google.com/earth/client/advanced/previous/GoogleEarthLinux.bin

いつ無くなるか分からないので確保しておいた方がよいと思います。

一応、下図のように動いています。

SS-GoogleEarth-610-001.jpeg

SS-GoogleEarth-610-002.jpeg

 

 ←メモリDDR-1333

    この前からの続きの「パソコン購入相談」を受けている件で
    メモリーはどうしようかな~と思って探していたら。
    このメモリー CL=7 です。普通CL=9。 違いでるのかな~。
    それと、この前「M/BはASUSのP8Z68-Vあたりかな・・・」
    と考えていましたが、P8Z68-Vのメモリークオリファイリストがあるんですね。
    http://www.asus.com/Motherboards/Intel_Socket_1155/P8Z68V/#MSL

 

 


nice!(3)  コメント(0) 
共通テーマ:パソコン・インターネット

【Ubuntu,Windows】Firefox 8.0.1 リリース -- クラッシュ問題対処 [コンピュータ全般]

以前の記事『【Ubuntu 11.10】Firefox 8.0.1がリリースされそう。それとFirefox 8.0がUbuntuでリリースされない理由。』で「firefox 8.0.1がリリースされそう」と書きましたが、2011/11/21にfirefox 8.0.1がリリースされました。

SS-firefox801-004.JPG

http://mozilla.jp/firefox/

リリースノートは下記。

http://mozilla.jp/firefox/8.0.1/releasenotes/

今回は、Mac OS X の「Java SE 6」プラグインのクラッシュ問題とWindows の「RoboForm」拡張機能のクラッシュ問題の対処のようです。

さっそくインストールしてみました。

[windows]

今回もアップグレードなので、メニューの[ヘルプ]→[firefoxについて]を開いてアップグレードしようと思ったら・・・できない(・・∂) アレ?

下図の「firefoxについて」のウインドウの薄い字で「Firefox は最新バージョンです」と書いていある所にボタンが出るはずが出ません。

SS-firefox801-003.JPG

仕方ないので、 「ここをクリック」を(上図の「Firefoxについて」のウインドウが一部かかっている部分にあります) 押して、Firefox Setup 8.0.1.exeをダウンロードして入れました。

恐らく、サーバー側の設定がまだだったのだと思います。(バグではないと思うのですが・・・)

 

[Ubuntu]

Ubuntu については、Ubuntu 11.10とUbuntu 11.04ではFirefox 8.0でさえまだ提供されていません。仕方ないので、Ubuntu 11.10(Oneiric)にマニュアルで入れてみました。

ただし、global-menu エクステンションが無いのでUnityでグローバルメニューが使えません。

1) ダウンロード

Ubuntu 11.10で http://mozilla.jp/firefox/ から firefox-8.0.1.tar.bz2 をダウンロードします。

2) 展開

端末から

cd /usr/local/lib

sudo tar xf /<* ダウンロードディレクトリパス*>/firefox-8.0.1.tar.bz2

3) 設定

Firefox 7.0.1のものを起動スクリプトとして利用するために下記を入力します。

cd /usr/local/bin

sudo cp /usr/bin/firefox .

sudo vi firefox  #エディタはお好きなのを

ここで始めの方に

MOZ_LIBDIR=/usr/lib/firefox-7.0.1

と記述している所を、下記に書き直してセーブします。

MOZ_LIBDIR=/usr/local/lib/firefox

次にサーチエンジンを切り替えます。firefox 左上の検索欄で選べる検索エンジンの事です。必要な方のみ行って下さい。

cd /usr/local/lib/firefox/searchplugins

sudo cp twitter-ja.xml /usr/lib/firefox-addons/searchplugins/ja/.

cd ..

sudo rm -rf  searchplugins

sudo ln -s /usr/lib/firefox-addons/searchplugins/ja searchplugins

これで完了です。

SS-firefox801-002.JPG

2011/11/22の正午時点で、Ubuntu 10.04(Lucid)~Ubuntu 11.10(Oneiric)では8.0.1をビルドもしていませんでした。いつ出るのかな??

 

 ←ASUS マザーZ68チップセット LGA 1155

   この前からの「パソコン購入相談」のつづきです。
   マザーボードはこれかな。それかこの上位のPRO。
   私はかなり長くASUSを使っていて、現在はP5Qです。
   1つ前はP4PE使っていて、最後にマザーが壊れて
   PCがダメになりました。
   一度だけGigabyte使った事あります。結構良かった。


nice!(1)  コメント(0) 
共通テーマ:パソコン・インターネット

【Ubuntu 11.10:Gnome3】Gnome Shellでウインドウが1つも無い状態でアクティビティボタンを押した場合に、直接アプリケーションメニューが出るようにする方法 [ubuntu]

Gnome Shell 3.2.1(Ubuntu 11.10上)を使っていて、アプリケーションを起動しようと思ったら、まずアクティビティボタンを押して下図の画面を出します。

SS-default-activites-005.JPG

そして、次に上部の「アプリケーション」のタブを押してメニュー画面を出します。(下図)

SS-default-activites-002.JPG

ここで、起動したいアプリケーションを選択して起動します。

ところで、ログイン後に起動しているウインドウが1つも無いのに、1つ目のスクリーンショットの画面がでるのは意味がない方がほとんどだと思います。起動しているウインドウが1つも無い時はアクティビティボタンを押したら、すぐに上図の画面に切り替わった方が便利だと思います。

というわけで、ちょっとした改造をして見ました。

< 変更方法 >

端末から下記を入力します。(エディタはお好きなもので・・・)

sudo vi /usr/share/gnome-shell/js/ui/viewSelector.js

そうしたら、下記の記述を探します。行番号は469行目あたりです。

    _switchDefaultTab: function() {
        if (this._tabs.length > 0)
            this._switchTab(this._tabs[1]);
    },

これを下記に書き直してセーブします。

    _switchDefaultTab: function() {
        if (this._tabs.length > 0) {
            let appSys = Shell.AppSystem.get_default();
            let allApps = appSys.get_running ();
            if ( allApps.length != 0) { 
                this._switchTab(this._tabs[0]);
            } else {
                this._switchTab(this._tabs[1]);
            }
        }
    },
 

後はgnome-shellを再起動すればOKです。

そうすると、下図の画面でアクティビティボタンを押すと、

SS-default-activites-001.JPG

いきなり下図の画面になります。

SS-default-activites-002.JPG

もし下図のようにアプリケーションが立ち上がってる状態でアクティビティボタンを押すと、

SS-default-activites-003.JPG

下図の画面になります。

SS-default-activites-004.JPG

リカバリーは元の記述に下記戻してください。

それで、常にアクティビティボタンを押すとアプリケーションメニューが出るようにするには、 書き直すコードが下記です。

    _switchDefaultTab: function() {
        if (this._tabs.length > 0) {
            this._switchTab(this._tabs[1]);
            Main.overview.workspaces.actor.hide();
            Main.overview.workspaces.actor.opacity = 255;
        }
    },

いずれもある程度は動かしていますが、私一人が確認しただけですので、理解した上で変更を行ってください。

 

 ←ビデオカード ATI Radeon HD 6850

 この前からの「パソコン購入相談」の
   続きで、ビデオカードはこれかな・・・
   nVidiaは使ったこと無いので良く分からないし
   なんか値段が高い。
   このあたりが妥当かな~と思います。
   一応、2011/11/21時点の価格.comで
   売れ筋ランキングNo.1です。


nice!(0)  コメント(0) 
共通テーマ:パソコン・インターネット

【Ubuntu 11.10】Latex(platex)環境のインストール [ubuntu]

都合で、Latexが必要になりました。

http://ja.wikipedia.org/wiki/LaTeX

Latexは簡単に言うと、マイクロソフト-ワードのようなドキュメントを作成するためのソフトです。ただ、決定的に違うのは、マイクロソフト-ワードでは文章を作成している段階で出力されるドキュメントのイメージが画面上でそのまま見えます(WYSIWYG)。それに対して、HTMLみたいなマークアップランゲージを使って、文章のレイアウトを記述します。ですので、作成中は出力イメージが見えませんし、レイアウトの為の命令文を記述する必要があります。すなわち、Latexでドキュメントを作成しようと思うと、HTMLを直接編集するのと同程度の勉強が必要だということです。

一見、使いづらいように思いますが、記述したファイルが平文(テキストファイル)なので簡単なスクリプトやコマンドでレイアウトや文章を一括変換できたりします。(例えば「佐藤さん」を「山本さん」に置き換えるとか・・)特に、大量の複数ファイルの場合は効果が大きいです。

それでインストールしたわけですが、下記のサイトが役に立ちました。(^人^)感謝♪

(サイト1)https://wiki.ubuntulinux.jp/JapaneseLocalizedDerivative/LaTeXForJapanese

(サイト2)http://oku.edu.mie-u.ac.jp/~okumura/texwiki/?Linux%2FUbuntu

(サイト3)http://www10.atwiki.jp/shirayuu/pages/64.html

1つめのUbuntu JapanのWikiの方ですがちょっと古いです。(サイト2)はUbuntuでのLatex関係の記事のリンク集として使えます。それで(サイト3)の「気の向くままに ~備忘録@wiki~ - Ubuntu Linux 11.10 - LaTeX環境」を後で発見して、設定などはこちらの方を参照するのが良いかと思います。

それで、Ubuntu 11.10でLatexをインストールする際に問題となるのは、 latex-env-ja,latex-extra-jaの2つのパッケージが存在しない事です。でも、この2つのパッケージは中身はほとんどありません。何をするためのパッケージかというと、debian/controlファイルにdependとして複数のパッケージが記述してあって、latex-env-ja,latex-extra-jaをインストールすれば勝手にLatexを使うのに必要なパッケージをインストールしてくれる仕組みです。

というわけで、横着な私はUbuntu 10.10用のlatex-env-ja,latex-extra-jaを利用してインストールする方法しました。

 

< インストール >

下記を順に端末から入力して下さい。

cd ~

mkdir latex_work

cd latex_work

sudo apt-get install gdebi

wget https://launchpad.net/~japaneseteam/+archive/ppa/+files/latex-env-ja_1.0-0ubuntu1%7Eja4_all.deb

wget https://launchpad.net/~japaneseteam/+archive/ppa/+files/latex-extra-ja_1.0-0ubuntu1%7Eja6_all.deb

sudo gdebi latex-env-ja_1.0-0ubuntu1~ja4_all.deb

sudo gdebi latex-extra-ja_1.0-0ubuntu1~ja6_all.deb

sudo jisftconfig add

cd ..

rm -rf  latex_work

※gdebiを起動した時にインストールするか尋ねられますので「y」を押して下さい。それから、dpkgコマンドだと依存関係を修正してくれませんが、gdebiだと依存関係にあるパッケージをダウンロードして修正してくれます。

これで、Latexの環境が整います。

後は、PDFを出力した時にAdobe Readerで見たければ下記でインストールして下さい。

sudo apt-get install -y adobereader-jpn

それと、作成する.texファイルはEUCコードでないとダメなので私は下記でnkfを入れました。

sudo apt-get install nkf

私はフォント関係は特に不満が無かったので特に設定していません。xdviでdviファイルを見たりする場合のフォント設定などは本記事のリンクのサイトを参考にして下さい。その他の問題も上記リンクで探してみて下さい。

 

< 使い方 >

Latexの記述方法は他のサイトや本にまかせるとして、仮にsample-jis.texというファイルを作ったとします。これをPDFで出力するには、端末から

nkf -d -e  sample-jis.tex > sample.tex

platex sample.tex

dvipdfmx sample.dvi

これでpdfが作られます。見るのなら下記で見れます。

acroread sample.pdf

以上です。

 

 ←Latexの解説本

   私にとってLatexの解説本というとこれ。
   ただ、読んでいたのはかなり昔ですし、自分の
   持ち物ではなかったのでどんな内容だったかは忘れました。
   結構、読みやすかったように思います。
   そもそもLatexを使うの何年ぶりだろう??


nice!(2)  コメント(0) 
共通テーマ:パソコン・インターネット

【Ubuntu 11.10】ファイルマネージャー(Nautilus)でファイルをダブルクリックした時に起動するアプリケーション(つまり、デフォルトアプリケーション)を変える方法 [ubuntu]

1つ前の記事『【Ubuntu 11.10】ファイルマネージャー(Nautilus)でファイルを右クリックした時に、開くアプリケーションを追加する。(オマケ付き)』の< オマケの拡張 >の項目の部分で、デフォルトで起動するアプリケーションを変えるの方法を記述しました。

簡単に言うと、/etc/gnome/defaults.listにファイルの種類(MIME Type)とアプリケーションエントリーが一対で列挙してあって、これによってファイルの種別毎に起動するデフォルトのアプリケーションが決まります。

1つ前の記事ではこれを変更しました。しかし、この方法ではシステム全体に影響してしまって他のユーザーのデフォルトも変わってしまいます。

それで、そういえば「システム設定」で「システム情報」を選んで(下図参照)、

SS-mimetype-003.JPG

「デフォルトのアプリケーション」でウェブとかメールはデフォルトを変えられます。(下図参照)

SS-mimetype-006.JPG

これはシステム全体には影響しなくて、設定したユーザー限定です。

というわけで、1つ前の記事と同じ効果ですが、設定したユーザー限定でデフォルトアプリケーションを変更する方法を記述します。もちろん、こちらの方法を推奨します。

 

< やり方 >

下図のようにxmlファイルをダブルクリックすると、

SS-mimetype-001.JPG

デフォルトでは下図の様にFirefoxが起動します。

SS-mimetype-002.JPG

でも、Firefoxでは編集が出来ないので、デフォルトではgeditを起動するというのを例にして説明します。

 

1) mimeapps.listがあるか確認

端末から下記を入力します。

cd ~/.local/share/applications

ls mimeapps.list

ここでls の結果で「mimeapps.list」と出ればOKです。もし、cdコマンドが失敗したり、lsコマンドで「ls: mimeapps.list にアクセスできません: そのようなファイルやディレクトリはありません」とでたら次の事をして下さい。

まず、「システム設定」で「システム情報」を選んで、左側の欄を「デフォルトのアプリケーション」を選んで、どれでもよいので適当にデフォルトアプリケーションを一旦替えて下さい。そしたら、また戻して下さい。本記事の1番目と2番目のスクリーンショットを参考にして下さい。

そうすると、デフォルトアプリケーションの情報をセーブする為に mimeapps.listを作成してくれるはずです。

 

2) mimeapps.listの編集

端末から下記を入力します。

gedit mimeapps.list

そしたら、下図の記述の部分があるはずです。

[Default Applications]
audio/x-vorbis+ogg=banshee.desktop
video/x-ogm+ogg=banshee.desktop
image/jpeg=eog.desktop
x-scheme-handler/mailto=thunderbird.desktop
x-scheme-handler/http=firefox.desktop
x-scheme-handler/https=firefox.desktop

[Default Applications]の下に何行あるか各ユーザーによって違いますが、次の部分と空行で切れているか、行末までのはずです。

そしたら、上記の部分の後(上の例では x-scheme-handler/https=firefox.desktopの後)に下記の行を追加します。

text/xml=gedit.desktop

下図参考。

SS-mimetype-004.JPG

そしたらセーブします。

これで完了。今度はxmlのファイルをダブルクリックすると、下図のようにgeditが起動します。

SS-mimetype-005.JPG

以上です。

ファイルの種類(MIME Type)と各ファイルのデフォルトアプリケーションについては、下記のコマンドとかで見て下さい。

less /etc/gnome/defaults.list

 

< ついでに分った事 >

本記事の2番目のスクリーンショットを見ると分りますが、システム設定から変更できるデフォルトアプリケーションの項目は、ウェブ、音楽など全部で6種類です。

それで、それぞれどのファイルの種類が影響があって、どこからアプリケーションの候補を集めているのだろうと思ったら・・・

gnome-control-centerのソースコードの panels/info/cc-info-panel.c の930行目あたりに下記の記述がありました。

static void
info_panel_setup_default_apps (CcInfoPanel  *self)
{
  info_panel_setup_default_app (self, "x-scheme-handler/http", "web-label",
                                1, 2, 0, 1);

  info_panel_setup_default_app (self, "x-scheme-handler/mailto", "mail-label",
                                1, 2, 1, 2);

  info_panel_setup_default_app (self, "text/calendar", "calendar-label",
                                1, 2, 2, 3);

  info_panel_setup_default_app (self, "audio/x-vorbis+ogg", "music-label",
                                1, 2, 3, 4);

  info_panel_setup_default_app (self, "video/x-ogm+ogg", "video-label",
                                1, 2, 4, 5);

  info_panel_setup_default_app (self, "image/jpeg", "photos-label",
                                1, 2, 5, 6);
}

ヾ(--;)ぉぃぉぃ 影響するMIME Typeは1つづつで、それもハードコード・・・大体、音楽とかならaudio/x-mp3の方が実用的では??

それでどうやってリストを作ってるかというと、

/usr/share/applications の中のエントリーファイル.desktopの中の"MimeType=....."に、上記ソースコードのMIME Typeと一致する記述があるものを集めているらしい。

ただ、実際には update-desktop-database を行って作成されたMIME Tyesキャッシュ(/usr/share/applications/mimeinfo.cacheから抜き出しているのかもしれません。(update-desktop-databaseを入力していない状態を確かめませんでした。)

しかし、デフォルトのアプリケーションをあまり替えると後で困るかな??

 

 ←CPU i7-2600K

    この前から受けているパソコン購入相談の続きです。
    CPUを今すぐ購入するならこれにすると思う。
    でも、ちょうどCPUは i7-3930Kが出て切り替わり時期。
    i7-3930Kは最近出たのでよくわからないし・・
    もう少し時間があるなら、待つのも手かな~。


nice!(2)  コメント(0) 
共通テーマ:パソコン・インターネット
メッセージを送る

この広告は前回の更新から一定期間経過したブログに表示されています。更新すると自動で解除されます。