So-net無料ブログ作成

【Ubuntu 12.04 Beta 2】AMD(ATI) Catalyst 12.4 (fglrx 8.961) リリース --- またカーネルモジュールのビルドが失敗する [ubuntu]

AMD(ATI) Catalyst 12.4 (fglrx 8.961) リリースされました。

SS-fglrx-8961-001.jpeg

ダウンロードリンク: 

http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx

リリースノートなのですが、Phoronixの方は本記事を記述している際に記事がでていません。

私はUbuntu 12.04のリポジトリからインストールできるfglrx 8.960とほとんど変わらないのではないかと、推測しています。

インストールに関しては、『【Ubuntu 12.04 Beta 1】AMD(ATI) Catalyst ドライバ 12.2 (fglrx 8.95) リリース。-- カーネルモジュールのビルドエラーが出る(仮対処)』の問題が残っています。

ですので、fglrx 8.960のパッケージに入っている下記のパッチをカーネルビルド中に読み込むようにしてインストールする必要があります。

fix-build-issue-on-i386-where-TS_USEDFPU-is-no-longe.patch

というわけですので、面倒だし、特にメリットが今のところないので、インストール方法は省略です。リポジトリーからインストールした方がよっぽど良いです。

一応、色々なセッションで動くか試してみました。

< ubuntu (unity 3d) >

SS-fglrx-8961-002.jpeg

Cubeで回した時にフリッキング問題(下記)はfglrx 8.961でも出ます。

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/862430

<Gnome Shell 3.4.1 >

SS-fglrx-8961-003.jpeg

一番安定してるかな・・・

余談ですが、gnome-shell 3.4.1だと今現在(4/25)あるgtk-3.0やgnome-shell用のテーマは手を加えないと使えません。(特に修正の必要が多いのが、オーバービューモード、パスワードの要求画面です。)

< Cinnamon >

SS-fglrx-8961-004.jpeg

アプリを起動したときに、時々画面が乱れることがあります。

<Kubuntu (KDE) >

SS-fglrx-8961-005.jpeg

普通に動きます。

< Lubuntu >

SS-fglrx-8961-006.jpeg

問題ないです。

< xfce >

SS-fglrx-8961-007.jpeg

これも問題なしです。このセッションが一番軽く感じるかな・・

< xbmc >

SS-fglrx-8961-008.jpeg

問題なしです。

明日あたりにUbuntu 12.04が出る予定ですが・・・、AMDのサイトからドライバをダウンロードしてfglrxを入れようとしたら、カーネルモジュールのビルドが失敗して上手く行かないというのが多発しそう。。。

 

 ← AMD Radeon HD 7750

    かなり7000番台が出回ってますね。
    ただ、7000番台にLinuxをインストールするのって
    大変そう。
    現時点でオープンソースのドライバが動いたって
    聞いてない。ということはnomodeset(KMSなし)で
    インストールして、 /etc/default/grubのオプションにも
    nomodesetを記述して、
    flgrx(8.960以降)をインストールするしかないのかな??


nice!(0)  コメント(0) 
共通テーマ:パソコン・インターネット

nice! 0

コメント 0

コメントを書く

お名前:
URL:
コメント:
画像認証:
下の画像に表示されている文字を入力してください。

Facebook コメント

メッセージを送る