So-net無料ブログ作成
検索選択

【Ubuntu 12.04 alpha 1】Google Earth 6.2 リリース & インストール --- 文字化け対処が簡単になった。 [ubuntu]

2012/1/26にGoogle Earth 6.2がリリースされたことをWEB UPD8で知りました。

WEB UPD8 :

http://www.webupd8.org/2012/01/google-earth-62-released-with-new-way.html

そこで、Ubuntu 12.04(precise) Alpha 1に入れてみました。

---2012/5/7追記---

※Ripe様のコメント頂いた時に気が付いたのですが、本記事はUbuntu 12.04 32bit版のみに関するやり方です。

※64bit版に関しては、Qtライブラリの32bit版を入れる必要があるはずです。(Ubuntu 12.04では未検証ですが、以前9.10 64bit版の時に行っています。)

※また、Ubuntu 11.10やそれ以前Ubuntuバージョンの文字化け対処方は本記事のやり方と違います。Ubuntuのバージョンによってやり方がそれぞれ異なるのでネットを検索してみて下さい。一応、私の過去の記事にも、いくつか過去のUbuntuバージョンの時に文字化け対処した記事がそれぞれあります。

---2012/5/7追記終わり---

SS-Google Earth62-002.jpeg

今回も文字化けを対処しなければならないのですが、Ubuntu 12.04 alpha 1に入っているQt4ライブラリの4.8.0を使って簡単に文字化けを対処できました。

ただ問題があって、google earth終了時に何故かクラッシュします。終了時なので、メニューから起動するとクラッシュしているのが分かりません。コマンドラインから起動すると分かります。

この状態で使用するとクラッシュログが ~/.googleearth/crashlogs に溜まるので、時々消してあげる必要があります。

それと、たまに下記のように写真の画像が見ている途中で、突然見れなくなることがあります。

SS-Google Earth62-004.jpeg

この場合は、もう一度写真を開き直すか、上図のように下にサムネイルがある場合には他を選択してから戻ってくると見れます。

もう1つあって、コマンドラインから起動するとUnity ランチャー上にアイコンが出ません。。

※これらの問題は私の環境だけなのか、わかりません。

 

< インストール方法 >

1) ダウンロード

下記のページに行って、「google earth 6をダウンロード」のボタンを押してgoogle earthをダウンロードします。

http://www.google.co.jp/intl/ja/earth/index.html

この時にパッケージを選ぶ事になりますが、「32 ビット .deb(Debian/Ubuntu」を選んでください。(デフォルトで選択されているはずです。) もちろん、64bitバージョンの方は「64 ビット .deb(Debian/Ubuntu)」を選んでください。

私は64bit版は試していません。ただ、64bit版のパッケージを展開してみて32bit版とdiffを取ったらまったく同じでした。また、64bit版に入っているshared library(拡張子.so)をfileコマンドで調べてみても、実際は32bitでした。

2) 必要なファイルのインストール。

下記のコマンドを端末から入力します。

sudo apt-get install libqtcore4 libqtgui4 libqt4-webkit libqt4-network libphonon4 libqt4-xmlpatterns lsb-core libfreeimage3 gtk2-engines-pixbuf

※上記は一行です。

恐らく上記で足りるはずですが、私の環境では既にいくつか入っていたので、上記では足りない場合もあるかもしれません。

3) google earthのインストール

google earthをダウンロードしたディレクトリにカレントディレクトリを移動して下記のコマンドを入力します。

sudo dpkg -i google-earth-stable_current_i386.deb

4) Qt ライブラリとプラグインの入れ替え(文字化け対処)

下記のコマンドを入力していきます。

cd /opt/google/earth/free

sudo mv libQtCore.so.4 libQtCore.so.4.org

sudo mv libQtGui.so.4 libQtGui.so.4.org

sudo mv libQtNetwork.so.4 libQtNetwork.so.4.org

sudo mv  libQtWebKit.so.4 libQtWebKit.so.4.org

退避するだけでOKです。そうすれば/usr/lib/i386-linux-gnuのディレクトリにあるQt4ライブラリを読みに行きます。

---2011/2/1 追記---

下記のOMG! Ubuntuの記事を見つけました。

http://www.omgubuntu.co.uk/2012/01/how-to-make-google-earth-look-native-in-ubuntu/

上記記事では、さらに下記のコマンドを追加で入力をするのと同等な事をしています。

sudo apt-get install libcurl3

sudo mv libcurl.so.4 libcurl.so.4.org

sudo mv libGLU.so.1 libGLU.so.1.org

sudo mv libnss_mdns4_minimal.so.2 libnss_mdns4_minimal.so.2.org

こちらも試してみて、google earthは動きました。

--- 2011/2/1 追記終わり ----

次にimageformat pluginsを変更します。

cd plugins/imageformats

sudo mv libqgif.so libqgif.so.org

sudo mv libqjpeg.so libqjpeg.so.org

sudo ln -s /usr/lib/i386-linux-gnu/qt4/plugins/imageformats/libqgif.so .

sudo ln -s /usr/lib/i386-linux-gnu/qt4/plugins/imageformats/libqjpeg.so .

5)  libfreeimages3ライブラリのプレロード

下記のコマンドを入力します。

cd /opt/google/earth/free

sudo vi google-earth #エディタはお好きなのを・・・

ここで最終行まで行って、下記の青字の部分を付け足します。

---------------------------------

   ~ 前略 ~

script_path=$(FindPath $0);

cd $script_path;

export LD_PRELOAD=/usr/lib/libfreeimage.so.3

LD_LIBRARY_PATH=.:$LD_LIBRARY_PATH ./googleearth-bin "$@"

------------------------------------

これでセーブ。

6) 起動

端末を終了して、メニューからgoogle earthを起動してみてください。文字化けせずに起動できるはずです。

 

 ←1000ルーメンの懐中電灯

    1000ルーメンてどんな明るさだ??
    レビューを読むと、車のヘッドライト並みたい・・・
    そうなると、懐中電灯というより投光器。
    ヨット乗るので欲しいけど、値段が高くて手がでない。


nice!(1)  コメント(2) 

nice! 1

コメント 2

Ripe

はじめまして。
Ubuntu 12.04 LTS64bit
googleearth6 64bit

Ubuntu 10.04 LTS32bit
googleearth6 32bit

どちらもコマンド 
$ aptitude install xfonts-shinonome
システム再起動
で文字化け解消されました。
(ヒントの文字化けは直りません)
いらないかもしれませんが参考までに。。
by Ripe (2012-05-06 10:52) 

あんきょ

☆Ripeさん☆
あらま、ビットマップフォントのインストールで文字化け直ってしまうんですね。知りませんでした。
情報ありがとうございます。

あ、それと今気が付いてのですが、Ubuntu 12.04の64bit版とUbuntu 10.04に入れていらっしゃいますが、本記事の通りやってしまいましたか?
もしそうなら、できなかったでしょう。(注意書きが足りませんでした。ごめんなさい)

Ubuntu 10.04の場合、Googleearth 5.2からQtのimageformatのプラグインを持ってこないとならないし、64ビット版は32ビット版のQtライブラリを持ってこないと動きません。(GoogleEarthが32bit版しかない為)

以前は64bit版ならgetlibsというツールで32bit版のライブラリを簡単に持ってこれたのですが現在はリンクが切れていてgetlibsが入手できません。パッケージを解体して入れるしかなさそうです。
by あんきょ (2012-05-07 13:43) 

コメントを書く

お名前:
URL:
コメント:
画像認証:
下の画像に表示されている文字を入力してください。

メッセージを送る

この広告は前回の更新から一定期間経過したブログに表示されています。更新すると自動で解除されます。

×

この広告は1年以上新しい記事の更新がないブログに表示されております。